Raw water system fixin’

As seen in my last post, Windchime wasn’t going anywhere without fixing the cooling system. I had established that water was running through the system ok, so I crossed my fingers and waited for the pump to be returned to me. Below, you can see the repaired pump.

pump

 

And with the cover on!

pumpcovered

 

Once I had screwed the cover on, it was time to reinstall it. I had a bit of trouble getting it into the right position, since the belt had to be taut and that made it a bit awkward. A bit of mucking around and it was firmly screwed in place!

pump installed

 

You can see it here – it’s that wheel at the bottom right, under the oil filter. The belt turns the wheel which turns the impeller which moves water round! Simple!

After installing it all back, I decided to test it out. The engine started immediately, and I straight away heard the sound of water coming out of the exhaust! I went round the side to check – and success!

If I have time tomorrow I am going to check out the tach, and see why that isn’t working. Else, move on Monday!

Matt

2 Comments

  1. Katharine Hepburn: “My but she’s yar!”
    Here’s to Windchime and a bottle of bubbly when the time comes.

  2. Hi Matthew — Didn’t mean to be anonymous.
    “What can we gain by sailing to the moon if we are not able to cross the abyss that separates us from ourselves? This is the most important of all voyages of discovery, and without it, all the rest are not only useless, but disastrous.”
    Thomas Merton…

Leave a Reply

Your email address will not be published. Required fields are marked *